Statistics
75317
11
0
94d
Badges
Dependencies

Downloads this Month Latest Stable Version

Install

composer require damejidlo/newrelic

Configure

Register NewRelicExtension in your config:

extensions:
    newrelic: Damejidlo\NewRelic\DI\NewRelicExtension(%consoleMode%)

newrelic:
	applicationName: fooBar
	applicationModules:
		web:
			'/api/': Api
			'/admin/': Admin
			'': Front
		console:
			'bin/foo.php ': Foo
			'': Console
	autorum: FALSE
	customTracers:
		- 'Doctrine\ORM\EntityManager::flush'

Put $_ENV settings (something like this) into index.php:

<?php

$_ENV['REQUEST_TIME_FLOAT'] = microtime(TRUE);

$container = require __DIR__ . '/../app/bootstrap.php';

$_ENV['COMPILATION_TIME_FLOAT'] = microtime(TRUE);

$container->getByType(\Nette\Application\Application::class)->run();
  • 3.0.1 3.0.1

    • Fix error in default baseDir value of PathUtils that was causing wrong resolution of application and transaction name for CLI requests.
  • 3.0.0 3.0.0

    • Drop support for PHP <7.2.
    • Use scalar type hints and return types everywhere.
    • Removed kdyby/events depedency.

    New

    • DI extension - allows configuration of application name, autorum on/off, custom tracers.
    • Client support for custom events.

    Major BC breaks

    • PresenterProfiler was removed - use named transactions and custom tracers instead.
    • Custom tracers for RouteList::match() and EntityManager::flush() are not enabled by default.
    • Application name is now resolved based on URL prefix, or command prefix and must be configured via DI extension.
    • NetteProfilingListener no longer automatically sends all request parameters to avoid leaking sensitive data.
  • 2.0.3 2.0.3

  • 2.0.2 2.0.2

  • 2.0.1 2.0.1

  • 2.0 2.0

    Support only PHP >= 7, Nette >= 2.4

  • 1.0.2 Welcome Nette 2.4!

    This release allows to install Nette 2.4

  • 1.0.1 Minor fixes

  • 1.0.0 First release

Is this addon outdated? Did you find an issue? Please report it.

Componette Componette admin@componette.com