Statistics
1432
6
0
1.8y
Badges
Dependencies

Nette bridge for PayU Api Build Status

Package Installation

The best way to install Social Plugins is using Composer:

$ composer require hostbox/api-payu-nette-bridge

Packagist - Versions

Nette Addons

or manual edit composer.json in your project

"require": {
    "hostbox/api-payu-nette-bridge": "~1.1.0"
}

Bridge Installation

Registration

extensions:
	payu: HostBox\Bridge\PayU\Extension

Configuration: Single POS

Autowire and inject is ON

payu:
	posId: '123456789'
	posAuthKey: 'qwertyuiop'
	key1: 'asdfghjkl'
	key2: 'zxcvbnm'

services:
    - MyFirstService
    - MySecondService(@payu.default) #manual inject

Configuration: Multi POS

Autowire and inject is OFF

payu:
	firstPOS:
		posId: '123456789'
		posAuthKey: 'qwertyuiop'
		key1: 'asdfghjkl'
		key2: 'zxcvbnm'
	secondPOS:
		posId: '987654321'
		posAuthKey: 'poiuytrewq'
		key1: 'lkjhgfdsa'
		key2: 'mnbvcxz'
		encoding: 'ISO'
		format: 'txt'

services:
    - MyFirstService(@payu.firstPOS)
    - MySecondService(@payu.secondPOS)
  • v1.1.0 Released version 1.1.0

    For stable hostbox/api-payu 1.0.*

  • v1.0.2 Released version 1.0.2

    Enjoy :)

Is this addon outdated? Did you find an issue? Please report it.

Componette Componette admin@componette.com