Statistics
469
1
0
86d
Badges
Dependencies

Confirmation dialog

Build Status Scrutinizer Code Coverage Scrutinizer Code Quality Latest Stable Version Composer Downloads License Dependency Status

Extension for creating confirm action dialogs for various items for Nette Framework

Installation

The best way to install ipub/confirmation-dialog is using Composer:

$ composer require ipub/confirmation-dialog

After that you have to register extension in config.neon.

extensions:
	confirmationDialog: IPub\ConfirmationDialog\DI\ConfirmationDialogExtension

Documentation

Learn how to use smart confirmation dialogs in documentation.


Homepage http://www.ipublikuj.eu and repository http://github.com/iPublikuj/confirmation-dialog.

  • v2.1.5 v2.1.5

    • Added support for Bower & created Bower package
  • v2.1.4 v2.1.4

    • Just code cleaning
  • v2.1.3 v2.1.3

    • Folder structure change
    • Added support for ipub/packages extension
  • v2.1.2 v2.1.2

    • Confirmer factory is now only internal
    • Some inject methods were transformed to constructors
    • Code cleaning
  • v2.1.1 v2.1.1

    • Minor fixes
    • Code cleaning
  • v2.1.0 v2.1.0

    • Added support for Nette 2.4
    • Upgraded to PHP7
    • Dropped PHP5.6
  • v2.0.4 v2.0.4

    • Fixed getting confirmer component. thx to @brychta-v
    • Fixed missing class in bootstrap template. thx to @juniwalk
    • Added abbility to skip displaying confirmer dialog
  • v2.0.3 v2.0.3

    • Added code coverage tests
    • Updated documentation
  • v2.0.2 v2.0.2

    • Updated template & layout setters
    • Updated documentation
  • v2.0.1 v2.0.1

  • v2.0.0 v2.0.0

    • Complete refacotring
    • Confirmers are as controls
  • v1.0.0 v1.0.0

    • First stable version

Is this addon outdated? Did you find an issue? Please report it.

Componette Componette admin@componette.com