Statistics
403
1
0
265d
Badges
Tags
utils
Dependencies

Nette PHP Server

Build Status

Nette console commands for running application in php builtin server.

Requirements

Nette PHP Server requires PHP 5.6 with pcntl extension.

Installation

The best way to install Nette PHP Server is using Composer:

$ composer require kdyby/nette-php-server

You can enable the extension using your neon config.

extensions:
    console: Kdyby\Console\DI\ConsoleExtension
    server: Kdyby\NettePhpServer\DI\PhpServerExtension

Configuration

This extension creates new configuration section server, but you don't need to configure anything unless you have different document root dir than www.

server:
    documentRoot: %appDir%/../htdocs
  • v0.3.0 v0.3.0

    Renamed package to Kdyby\NettePhpServer

  • v0.2.0 v0.2.0

    Added documentRoot configuration to PhpServerExtension.

  • v0.1.0 v0.1.0

    First release

Is this addon outdated? Did you find an issue? Please report it.

Componette Componette admin@componette.com