Statistics
4537
2
1
7d
Badges
Dependencies

Doctrine Extensions

Wrapper for Doctrine2 behavioral extensions, Translatable, Sluggable, Tree-NestedSet, Timestampable, Loggable, Sortable to Nette Framework.

Adapt to Nette Framework (2.3, 2.4)


Build Status Code coverage Licence

Downloads this Month Downloads total Latest stable Latest unstable

Discussion / Help

Join the chat

Install

composer require nettrine/extensions

Dependencies

Package Version
nette/di ~2.3.0 | ~2.4.0
gedmo/doctrine-extensions ~2.4.0

Inspired

Heavily inspired by these plugins, thank you guys.

Usage

By default, all behavioral extensions are enabled.

extensions:
    gedmo: Nettrine\Extensions\DI\DoctrineExtensionsExtension

gedmo: 
    translatable:
        translatable: cs_CZ
        default: cs_CZ
        translationFallback: off
        persistDefaultTranslation: off
        skipOnLoad: off

    annotations 
        loggable: on
        sluggable: on
        softDeleteable: on
        treeable: on
        blameable: on
        timestampable: on
        translatable: on
        uploadable: on
        sortable: on
        ipTraceable: on

Maintainers


Milan Felix Šulc

Josef Benjač

Thank you for testing, reporting and contributing.

  • v0.2 v0.2

    Bump! 👍

    Diff: v0.1...v0.2

    Changes:

    • changed package name to nettrine/extensions [#3]
    • fix namespace autoloading [#4]
    • improvements
  • v0.1 v0.1

    Bump 🔥 v0.1

Is this addon outdated? Did you find an issue? Please report it.

Componette Componette admin@componette.com