Statistics
1474
3
0
153d
Badges
Tags
tracy
Dependencies

tracy-gitpanel

Build Status Downloads this Month Latest stable


This is simple extension for Tracy which shows the information about current GIT branch.

not versioned project

versioned project

Installation

The recommended installation is using composer.

composer req nofutur3/tracy-gitpanel

Alternative way - in case you are not able to use composer. Download the source code (ie clone git repo) into your project and require it some way. For nette framework like this in your bootstrap file:

$configurator
    ->createRobotLoader()
    ->addDirectory(__DIR__ . 'path/to/library/');

Configuration

In your nette application it's simple, just add these lines to your config file. Depends on the structure of your config files, but you may use the basic config.neon file. I usually add the lines just in config.local.neon file because I don't need this extension in production mode.

Nette 2.3+
tracy:
    bar:
        - Nofutur3\GitPanel\Diagnostics\Panel

If you want to set up the protected branches (by default it uses just a master branch), just pass the array of branch names to the panel:

parameters: 
    protected-branches:
        - production
        - staging
tracy:
    bar:
        - Nofutur3\GitPanel\Diagnostics\Panel(%protected-branches%)
Older version of Nette:
nette:
    debugger:
        bar: 
            - Nofutur3\GitPanel\Diagnostics\Panel

Standalone Tracy

In case you are using Tracy without Nette, you can add GitPanel this way:

\Tracy\Debugger::getBar()->addPanel(new \Nofutur3\GitPanel\Diagnostics\Panel());

Or with protected branches:

\Tracy\Debugger::getBar()
    ->addPanel(new \Nofutur3\GitPanel\Diagnostics\Panel(['production','staging']));
  • v0.9.4 v0.9.4

    Improved CI
    Improved the panel UI
    Updated readme.md
    Ability to set up protected branches

  • v0.9.3 v0.9.3

    Fixed errors when the project is not under version control.

  • v0.9.2 v0.9.2

    Fixed namespaces; working

  • v0.9.1 v0.9.1

  • v0.9 v0.9

    First release.

Is this addon outdated? Did you find an issue? Please report it.

Componette Componette admin@componette.com