Statistics
2796
7
4
112d
Badges
Dependencies
  • php (>=5.4.0)

Google Map API

Latest stable Scrutinizer Code Quality Code Coverage

This component is stated for Nette framework and it simlifies working with a Google map.

Requirements

  • Nette Framework 2.1+

Installation

composer require olicek/google-map-api:dev-master

and now the component can be registered in extensions in a neon config

extensions:
    map: Oli\GoogleAPI\MapApiExtension

The last step is to link 2 files to your page.

client-side/googleMapAPI.js
client-side/googleMapApiLoader.js

Documentation

  • v2.2 Released version 2.2

    • BC: extract loader to extra js file (googleMapApiLoader.js)
    • Fixed firefox bounds
    • Added Icon object
    • Added support for clickable static maps (with callable)
    • Fixed scrollable
    • Added bower.json
    • Added Marker clusterer options
    • Added support for custom marker callbacks

    For more info: v2.1...master

  • v2.1 Released version 2.1

    • remove dependency to jQuery
    • add support for disable scrollable map
    • Add support for waypoints
  • v2.0 Released version 2.0

    • Add DI extension
    • Add markerClusterer support
    • Bounds bug fix
    • Zoom bug fix
    • Auto open message bug fix

Is this addon outdated? Did you find an issue? Please report it.

Componette Componette admin@componette.com