Statistics
5
0
0
1.2y
Badges
Tags
api
Dependencies

iqrf-cloud-nette

build status Packagist Coveralls HHVM Dependency Status Gitter GPLv3

IQRF Cloud API wrapper for Nette Framework

Installation

The best way how to install IQRF Cloud API wrapper is to use a Composer:

composer require roman3349/iqrf-cloud-nette

Configuration

Using DI Extension (Nette 2.1+)

Add following lines into your config.neon file.

extensions:
	iqrf: IQRF\Cloud\DI\IQRFExtension

iqrf:
	apiUrl: 'https://cloud.iqrf.org/api/api.php'
	apiKey: 'k6wuaem3wtaiupmnuc7cziuvaup2fxim'
	ipAddr: '127.0.0.1'
	userName: 'admin'

php:
    date.timezone: Europe/Prague
    ...

More about DI container extensions you can find here: https://doc.nette.org/en/2.3/di-extensions

Documentation

Documentation you can found on this page.

License

iqrf-cloud-nette is licensed under the GPLv3 license:

Copyright (C) 2016 Roman Ondráček

This program is free software: you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation, either version 3 of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program. If not, see http://www.gnu.org/licenses/.

No release at this moment. Try to create first one.

Is this addon outdated? Did you find an issue? Please report it.

Componette Componette admin@componette.com